• Python If-Else in hacker rank challenge Not Weird and Weird

    Given an integer, , perform the following conditional actions:

    • If  is odd, print Weird
    • If  is even and in the inclusive range of  to , print Not Weird
    • If  is even and in the inclusive range of  to , print Weird
    • If  is even and greater than , print Not Weird

    Input Format

    A single line containing a positive integer, .

    Constraints

    Output Format

    Print Weird if the number is weird. Otherwise, print Not Weird.

    Sample Input 0

    3
    

    Sample Output 0

    Weird
    

    Explanation 0


     is odd and odd numbers are weird, so print Weird.

    Sample Input 1

    24

    Sample Output 1

    Not Weird 

    Solution:-


    n = int(input().strip())

        if n%2 ==0:
            if n>=2 and n<=5 :
                print("Not Weird")
            if n>=6 and n<=20 :
                print("Weird")
            if  n>=24 :
                print("Not Weird")
        else:
            print("Weird")

  • 0 comments:

    Post a Comment

    GET A FREE QUOTE NOW

    Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod tincidunt ut laoreet dolore magna aliquam erat volutpat.

    Search This Blog

    Powered by Blogger.

    Blog Archive

    ADDRESS

    4759, NY 10011 Abia Martin Drive, Huston

    EMAIL

    contact-support@mail.com
    another@mail.com

    TELEPHONE

    +201 478 9800
    +501 478 9800

    MOBILE

    0177 7536213 44,
    017 775362 13